Empiezapori es agente digitalizador de la ayuda Kit Digital

Somos agente digitalizador de la ayuda Kit Digital. Te ayudamos en la creación de tu sitio web o comercio electrónico y gestionamos tus redes sociales.
Llámanos (93 470 00 37) o rellena el formulario y nos pondremos en contacto contigo. Te ayudamos a gestionar la ayuda.
Para más información y contacto haz clic en el siguiente enlace.

Instalación o actualización Dolibarr 3.9 o superior en servidores 1and1

Tras unos días investigando, porqué no me dejaba actualizar dolibarr a de la versión 3.8.4 a la versión 3.9.0 o 3.9.1 en los servidores 1and1, cuando en versiones anteriores lo hacía sin problema. Ya he encontrado la causa y está en un archivo situado en la carpeta «htdocs/install» cuyo nombre es «inc.php».

Dentro de este archivo en la línea 87, esta el siguiente código:

if (empty($dolibarr_main_db_port) && ($dolibarr_main_db_type=='mysqli' || $dolibarr_main_db_type=='mysql')) $dolibarr_main_db_port='3306'; // For backward compatibility

El problema está en el puerto 3306, que hace que por defecto utilice ese en caso de estar vacio en el archivo conf.php.

En el caso de 1and1 debe estar vacio, por lo que deberemos borrar de la línea el número 3306.

Con esto la instalación o actualización ya estará preparada en nuestro servidor 1and1.

Espero que os haya ayudado y no tengais que perder tanto tiempo como yo, y en siguientes versiones ya esté corregido.

Deja un comentario

Tu dirección de correo electrónico no será publicada.

Ir arriba